软件工程
当前位置 :首页信息技术软件工程

安装php-gd出现Missing Dependency: libt1.so.5报错的解决办法

来源: 作者: 时间:2013-03-30 点击:

centos下通过yum在线安装php5.2.x版本的php-gd的时候,会报模块依赖错误,错误提示如下:

Missing Dependency: libt1.so.5()(64bit) is needed by package php-gd-5.2.17-1.el5.x86_64
Error: Missing Dependency: libt1.so.5()(64bit) is needed by package php-gd-5.2.17-1.el5.x86_64
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

解决办法:

下载安装对应版本的t1lib的rpm包后,重新yum安装php-gd即可。rpm包下载路径如下:
32位:
http://rpm.pbone.net/index.php3/stat/4/idpl/5782702/dir/centos_5/com/t1lib-5.1.0-9.el5.kb.i386.rpm.html
64位:
http://rpm.pbone.net/index.php3/stat/4/idpl/5786767/dir/centos_5/com/t1lib-5.1.0-9.el5.kb.x86_64.rpm.html
(注意操作系统版本!)

 

上一篇:
下一篇: 已经是最后一篇
最新评论共有 位网友发表了评论
发表评论
用户名: 密码: 游客发言不需要密码